• Register
Plug-in Tutorial Build an EC-CUBE plug-in

Top Commentators

114

1

EC Mike

SHOGUNSHOGUN

32

2

hrbabu

SAMURAISAMURAI

29

3

Sumant Jha

SAMURAISAMURAI

29

4

justcubed

SAMURAISAMURAI

21

5

Ashok Kafle

SAMURAISAMURAI

21

6

shahith

SAMURAISAMURAI

14

7

Jeemusu

KABUKIKABUKI

14

8

Yangsin

KABUKIKABUKI

9

9

Zaw Hlaing Bwar

GEISYAGEISYA

8

10

Fei Liu

GEISYAGEISYA

Ranking Key

  • FUJISANFUJISAN1,000+ posts
  • SAKURASAKURA500+ posts
  • SHOGUNSHOGUN100+ posts
  • NINJYANINJYA50+ posts
  • SAMURAISAMURAI20+ posts
  • KABUKIKABUKI10+ posts
  • GEISYAGEISYALess than 10 posts

EC-CUBE first installation problem / error with .htaccess and database

0 votes

Trying to install EC-CUBE on my web domain, I was following the instructions from the EC-CUBE  user manual... but I did find 2 problems.

1- It is not possible to start with the installation.

SOLUTION: delete the .htaccess file in "http://www.yourwebsite.something/.../.../html/.htaccess

 

2- Going on with the first installation, I got an error in the connection with my database. My databese datas are correct, but I always get this kind of error.

 

Fatal error: An error occurred in DB processing. SQL: [PREPARE mdb2_statement_mysql_                                                                                                  FROM 'SET SESSION storage_engine = InnoDB'] PlaceHolder: [array ( )] MDB2 Error: unknown error _doQuery: [Error message: Could not execute statement] [Last executed query: EXECUTE mdb2_statement_mysql_                                                                                                  ] [Native code: 1286] [Native message: Unknown table engine 'InnoDB'] in /home/mhd-01/www.xxxxx.xx/htdocs/ecc1/data/class/SC_Query.php on line 1007

 

Note: I did try also creating many new databases and on a different domain. Always the same problem.

Can someone help me?

Arigatou gozaimasu....

asked 2014-06-02 by majin (160 points) GEISYAGEISYA
edited 2014-06-02 by majin

5 Answers

0 votes

Found a walkaround to skip this problem, but I don't know if it is right or wrong.

Deleted 1007 and 970 lines in .../data/class/SC_Query.php.

What do you think?

 

answered 2014-06-02 by majin (160 points) GEISYAGEISYA
0 votes
1. First of all, please check wheather your database added by the db user or not. If not, add your database to the db user.

2. During installation, please insert "localhost" as DB server in the Database settings wizard.
answered 2014-06-02 by hrbabu (1,680 points) SAMURAISAMURAI
Of course. I created the DB and the DB user too.
I had tried to insert "localhost" too, but the error is the same.
+1 vote
add DB server = localhost
answered 2014-06-03 by Sumant Jha (1,230 points) SAMURAISAMURAI
It didn't work.
Anyway for example, when I install Wordpress in a similar situation (different DB or differernt Host) I always use the same "DB address", not localhost.
0 votes
Do you made any changes in SQL files in the installation folder(html/install/sql/)? Sometimes data mismatch occurs errors during installation. I told before not about the creation of db user, but about to add the db user to the db. Sorry for repeatation, sometimes we overlook some common things. Thanks...
answered 2014-06-03 by hrbabu (1,680 points) SAMURAISAMURAI
Thank you for your answer.
I didn't any change to the SQL files. Just copied all by FTP.
Are you meaning that EC-CUBE needs an "added dedicated" DB user on my DB?
Anyway, on my host I can just create 1 user for each DB (limited DataBase number).
So, I can just use just that user.
0 votes
May be due to incorrect PEAR setting on your server.

On line 1007 EC-CUBE prepare the database connection and check its PEAR settings.

Find php.ini on your server and search for PEAR.

You will find something like this: include_path = ".;C:\xampp\php\PEAR"

change this path to exact PEAR location on your server.

May this will help you.

Thank You!
answered 2014-06-09 by Ashok Kafle (1,360 points) SAMURAISAMURAI
...